Management API Performance Degradation.

Incident Report for Supabase

Update

We have identified some anomalies that appear correlated to this issue and we are continuing to investigate.
Posted Jul 30, 2026 - 21:58 UTC

Update

We are continuing to investigate the issue.
Posted Jul 30, 2026 - 21:19 UTC

Investigating

We have been alerted that our management API is experiencing performance degradation due to intermittent network issues. Users who experience the problem are encouraged to log out and log back in to the dashboard as that has cleared the issue in many cases. We are actively investigating a persistent fix.
Posted Jul 30, 2026 - 20:51 UTC
This incident affects: Management API.