Project usage analytics API endpoints breakage

Incident Report for Supabase

Resolved

All analytics responses have returned to normal.
Posted Jun 16, 2026 - 17:01 UTC

Monitoring

The mitigation has been successful and analytics endpoints are all responsive. We will continue to monitor for stability.
Posted Jun 16, 2026 - 16:27 UTC

Identified

The component at issue has been identified and we are implementing mitigations. Analytics responsiveness on the impacted endpoint is begining to recover.
Posted Jun 16, 2026 - 16:22 UTC

Update

We are investigating the components involved in analytics endpoints updates to isolate any changes that could have caused this problem. The issue is limited to the usage.api-requests-count endpoint.
Posted Jun 16, 2026 - 16:18 UTC

Investigating

We are investigating a breakage in project usage analytics data propagation.
Posted Jun 16, 2026 - 15:47 UTC
This incident affected: Analytics.