Issues with new organisation creation and plan changes

Incident Report for Supabase

Resolved

This incident has been resolved.
Posted Sep 03, 2025 - 14:50 UTC

Monitoring

The issues with our upstream billing partner have been resolved, and we are no longer seeing elevated error rates and expect organization creation and plan changes to work as expected. We will continue to monitor to be sure things remain stable.
Posted Sep 03, 2025 - 13:11 UTC

Update

We are still seeing higher than usual errors for the requests to the upstream billing partner. We continue to work together to work towards full restoration.
Posted Sep 03, 2025 - 12:22 UTC

Identified

The error rates are still higher than usual for the requests to the upstream billing partner. We are working to restore everything to its normal state.
Posted Sep 03, 2025 - 11:17 UTC

Monitoring

New organisation creation and plan changes are working again, the platform is fully operational again. We will continue to monitor to make sure the problem does not resurface.
Posted Sep 03, 2025 - 11:10 UTC

Identified

We have identified issues with new organisation creation and plan changes due to an upstream outage with our billing partner. We are working to restore new organisation creation and plan changes as soon as possible.

Running projects should not be affected.
Posted Sep 03, 2025 - 10:43 UTC