Data and Auth API Connectivity issues in SA-East-1
Incident Report for Supabase
Resolved
This incident has been resolved.
Posted Jul 16, 2024 - 10:52 UTC
Monitoring
The ISP has fixed the issue and we are monitoring the situation.
Posted Jul 16, 2024 - 08:01 UTC
Identified
The problem has been narrowed down to an ISP having degraded performance with IPv6 traffic. Our CDN provider is working with the ISP to resolve the issue.
Posted Jul 16, 2024 - 06:26 UTC
Update
We're continuing to work with Cloudflare and AWS on identifying the source of the interruption between the two.

Affected connections are to projects hosted in the AWS sa-east-1 region, generally when contacted from us-east-1 (but potentially others as well).

Workarounds include:

- relocating client workloads to us-west-1
- temporarily using an IPv4 add-on (the interruption only seems to be affecting IPv6 traffic)
Posted Jul 16, 2024 - 04:18 UTC
Update
The connectivity issue seems to be affecting connections made from the AWS us-east-1 region (including, e.g. Vercel resources hosted in iad1), to projects hosted in the AWS sa-east-1 region.

Initiating requests from other AWS regions should work without issues, and can be used as a workaround (e.g. by moving client service/app hosting locations).

We're still working on a root cause and resolution.
Posted Jul 15, 2024 - 23:43 UTC
Update
There seem to be Cloudflare connectivity issues between some regions in North and South America, to our projects hosted in the sa-east-1 region.

Other regions seem to be unaffected.
Posted Jul 15, 2024 - 22:44 UTC
Update
We are continuing to investigate this issue.
Posted Jul 15, 2024 - 22:35 UTC
Investigating
We are currently investigating this issue.
Posted Jul 15, 2024 - 22:32 UTC
This incident affected: API Gateway and Auth.