Users Experiencing Network Connectivity Problems (India Region)

Incident Report for Supabase

Update

We are currently aware of an issue affecting reachability of Supabase projects for a subset of users based in India.
Supabase infrastructure remains fully operational.

We have confirmed that the projects of impacted users remain accessible from regions outside India.
Our investigation has confirmed that a service provider in the region is not serving the correct DNS responses for Supabase projects from their internal DNS resolvers.

We are following up through all available channels to work with the ISP to resolve this issue.
We also advise affected customers to also report the issue to their ISP.

The best workaround we have currently is for affected users to use an alternative DNS providers such as:
Cloudflare: https://1.1.1.1
Google https://developers.google.com/speed/public-dns
Quad9: https://quad9.net/

Alternatively users can use a VPN to avoid this issue

We will post a further update once the ISP has confirmed that the issue is resolved or additional information becomes available.
Posted Feb 24, 2026 - 16:39 UTC

Update

We have confirmed that the projects of impacted users remain accessible from regions outside India.
Our investigation is currently focused on an ISP-level block affecting users within India.

We advise affected customers to also report the issue to their ISP. Supabase infrastructure remains fully operational.

The best workaround we have currently is for affected users to use an alternative DNS providers such as:
Cloudflare: https://1.1.1.1
Google https://developers.google.com/speed/public-dns
Quad9: https://quad9.net/
Posted Feb 24, 2026 - 16:08 UTC

Update

We have confirmed that the projects of impacted users remain accessible from regions outside India.
Our investigation is currently focused on a potential ISP-level block affecting users within India.
Posted Feb 24, 2026 - 16:00 UTC

Update

We continue to work with customers to address their connectivity issues. We are also contacting the relevant network providers to work with them to resolve the issue.
Posted Feb 24, 2026 - 15:42 UTC

Identified

A DNS resolution issue is affecting customers in AP-South-1 and AP-Southeast-2. Certain ISP DNS servers appear to be unavailable, preventing connections to Supabase endpoints. Some users reported that switching to Cloudflare DNS (1.1.1.1) may restore connectivity. We advise affected customers to also report the issue to their ISP. Supabase infrastructure remains fully operational.
Posted Feb 24, 2026 - 15:13 UTC

Investigating

We have reports of customers having difficulties connecting to Supabase from locations accessing AP-south-1, including a number of reports from India. We are actively investigating the issue.
Posted Feb 24, 2026 - 14:46 UTC
This incident affects: Auth, Edge Functions and Compute capacity (ap-south-1).