Issues with Edge Function Deployment

Incident Report for Supabase

Update

We are continuing to investigate this issue.
Posted Jul 30, 2026 - 21:02 UTC

Update

Per-function deployment appears to be working successfully. However, bulk function deployments with the `supabase functions deploy` command appear to still be experiencing issues. Additionally, we are aware of reports of issues updating existing function deployments. We are continuing to investigate these issues.
Posted Jul 30, 2026 - 19:46 UTC

Update

We have determined and rolled back the change that led to this issue. Users who were experiencing issues with deployments should now be able to deploy successfully.
Posted Jul 30, 2026 - 18:28 UTC

Update

Only a subset of users appear to be impacted by the issue with Edge Function deployments. We are investigating the root cause.
Posted Jul 30, 2026 - 18:16 UTC

Investigating

We are aware of some users experiencing issues with Edge Function deployments.
Posted Jul 30, 2026 - 17:37 UTC
This incident affects: Edge Functions.