Degraded Supavisor performance in sa-east-1 region.

Incident Report for Supabase

Resolved

This incident has been resolved.

The impact began at 2:00 UTC causing a small fraction of queries in the affected region to be slower.
At 11:00 UTC, the issue escalated and became more apparent as p95 latency increased.
By 15:00 UTC, the degradation became widespread, with median query performance showing high variance and p95 consistently elevated.

Higher than usual connection times could also be perceived during the incident.
Posted Oct 26, 2025 - 20:02 UTC

Monitoring

We identified and replaced a faulty node in the sa-east-1 region. We are seeing query and connection times return to normal and will continue to monitor.
Posted Oct 26, 2025 - 19:14 UTC

Investigating

We are investigating degraded supavisor performance in the sa-east-1 region.
Posted Oct 26, 2025 - 18:51 UTC