We've determined that the connectivity issues are isolated to users accessing Supabase through Mullvad VPN and potentially other VPN providers. The root cause appears to be network disruptions involving a specific colocation/transit provider used by Mullvad, rather than an issue with Supabase or Cloudflare infrastructure.
We've reached out to Mullvad support, but as this is dependent on external providers, there are no further mitigation steps we can take internally. Users experiencing issues are advised to avoid affected VPN networks or contact their VPN provider directly for support.
The incident is now resolved
Posted May 13, 2026 - 20:35 UTC
Identified
Our investigation has identified traffic loss along a specific network path associated with a VPN exit point located in Western Europe.
Some customers are experiencing connectivity issues that impact a subset of users connecting through certain VPN providers, including Mullvad.
Customers impacted while using Mullvad can contact Mullvad support directly to help raise visibility into the issue from their side.
Posted May 13, 2026 - 19:50 UTC
Update
We are continuing to actively investigate the connectivity issues impacting access to Supabase APIs for some users.
Our team remains engaged in identifying the underlying cause and validating the scope of impact. We will continue to provide updates as our investigation progresses.
Posted May 13, 2026 - 17:31 UTC
Update
We are continuing to investigate connectivity issues impacting access to Supabase APIs, which may result in connection timeout errors or rejected connections for some users. At this time, we have narrowed the issue down to traffic originating from at least one VPN provider (Mullvad VPN). However, we cannot yet confirm whether additional VPN providers may also be impacted. We are actively working to identify the root cause and will continue to provide updates as we learn more.
Posted May 13, 2026 - 16:46 UTC
Investigating
We've observed traffic from upstream providers of a VPN provider is no longer reaching our servers. We're investigating the cause and will keep you updated.