Intermittent errors connecting to some Fly regions from eu-central-1 region
Incident Report for Supabase
Resolved
This incident has been resolved.
Posted Sep 13, 2024 - 21:06 UTC
Monitoring
Fly has found and fixed a misconfiguration in their edge network, and all connectivity from eu-central-1 to fly regions now appears to be working again.

We are monitoring for further issues, but things are looking good now.
Posted Sep 13, 2024 - 20:36 UTC
Update
We've worked with Resend on a workaround for the more general connectivity issues from AWS eu-central-1 to Fly, and at this time email actions should now be working again.

If you have other things that communicate between your Supabase service and Fly regions, you may still see some errors.

We are continuing to work with Fly and AWS to resolve the broader issue.
Posted Sep 13, 2024 - 19:16 UTC
Identified
We believe we have isolated these connectivity problems to a routing issue outside of Supabase networks, somewhere between AWS and Fly. We are working with both teams to resolve this issue.
Posted Sep 13, 2024 - 18:54 UTC
Investigating
While working with Resend on this issue, we discovered that there are periodic connectivity issues between our eu-central-1 and some Fly regions. We are investigating the cause of that now.

Users in eu-central-1 may continue to see periodic failures with email actions until this is resolved.
Posted Sep 13, 2024 - 17:44 UTC
Monitoring
Some customers in eu-central-1 are reporting intermittent errors sending emails due to periodic issues connecting to Resend. The Resend team is aware and is working towards a resolution. You can follow their status page here: https://resend-status.com/incident/428717
Posted Sep 13, 2024 - 16:54 UTC