Degraded Logging Ingestion impacting all regions

Incident Report for Supabase

Resolved

The issue affecting Supabase Log ingestion has been fully resolved.
Log ingestion across all services has returned to normal operation.
Posted Mar 12, 2026 - 13:53 UTC

Monitoring

A fix has been implemented and log ingestion is now stabilising.
We are seeing recovery across the affected services.
Our team is actively monitoring the system to ensure ingestion fully returns to normal.
Posted Mar 12, 2026 - 12:54 UTC

Investigating

We are currently investigating an issue affecting Supabase Logs that is causing partial log ingestion for some services.
Users may experience delays or errors when accessing logs related to Realtime, Storage, or Edge Functions logs.
The logs for these services may only be partially ingested.
The services remain fully functional, this is only impacting logs.
Postgres Logs are not impacted.

Our team is actively working to identify the root cause and restore normal performance as quickly as possible.
We will share another update as soon as more information becomes available.
Posted Mar 12, 2026 - 12:51 UTC
This incident affected: Analytics.