Dashboard Support Form Erroring on ticket submission

Incident Report for Supabase

Resolved

The increased retry intervals have made ticket opening much more stable, and things are looking good.

We apologize for the inconvenience!
Posted Jun 10, 2025 - 22:45 UTC

Monitoring

We've identified a race condition in the ticket submission process. We've added some resiliency here to avoid the race condition and handle failures more gracefully. This has been merged and we are monitoring the results.
Posted Jun 10, 2025 - 22:00 UTC

Investigating

Some users are seeing failures when attempting to submit a support ticket via the dashboard or via https://supabase.help - We are currently investigating.

In the mean time, you can also email us at support@supabase.com - please include the relevant project id for the project or projects you are seeing issues with.
Posted Jun 10, 2025 - 20:24 UTC