Query slowness for projects running Postgres version 14 in us-east-1 and ap-northeast-2

Incident Report for Supabase

Monitoring

The fix has been rolled out to us-east-1. We will continue to monitor both regions for stability.
Posted Sep 16, 2026 - 19:48 UTC

Update

The fix has been implemented for ap-northeast-2 and we're working on implementing the fix for us-east-1. We will continue to provide updates as progress is made.
Posted Sep 16, 2026 - 19:17 UTC

Update

We are continuing to work on a fix and will provide updates as things progress.
Posted Sep 16, 2026 - 18:32 UTC

Identified

Projects running Postgres version 14 in us-east-1 and ap-northeast-2 may experience query slowness. We've identified the cause and are working on a fix.
Posted Sep 16, 2026 - 17:53 UTC