Delayed DNS Propagation on New Projects due to Ongoing Cloudflare Issues
Incident Report for Supabase
Resolved
DNS Propagation has returned to normal, and we are seeing no lingering errors related to the Cloudflare Outage, which has also been resolved.
Posted Nov 07, 2023 - 13:36 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 06, 2023 - 22:55 UTC
Monitoring
We have worked with Cloudflare to get to the bottom of this, and a fix has been applied. We are monitoring for any further issues.
Posted Nov 06, 2023 - 16:41 UTC
Identified
We're again seeing issues in DNS propagation from Cloudflare.
Posted Nov 06, 2023 - 06:54 UTC
Monitoring
Cloudflare DNS propagation issues have subsided. Workflows that were impacted in the past should no longer see any disruptions.
Posted Nov 06, 2023 - 05:38 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 06, 2023 - 00:03 UTC
Identified
Cloudflare DNS propagation delays are once again impacting the creation of new projects, upgrades, and compute size changes. We're working with Cloudflare Support on this matter.
Posted Nov 06, 2023 - 00:03 UTC
Monitoring
DNS propagation speeds have returned to normal.

There might further disruptions until Cloudflare's incident is resolved and services are fully restored ( https://www.cloudflarestatus.com/incidents/hm7491k53ppg ).
Posted Nov 04, 2023 - 08:16 UTC
Update
Status from Cloudflare remains the same - DNS Updates are still degraded. New project creation and other DNS-related operations will work; however, they may be slower than normal until things are all clear on the Cloudflare side.

We're continuing to monitor any changes here, and will update again as more information becomes available.

More info here: https://www.cloudflarestatus.com/incidents/hm7491k53ppg
Posted Nov 03, 2023 - 22:18 UTC
Identified
This is related to the ongoing Cloudflare incident here: https://www.cloudflarestatus.com/incidents/hm7491k53ppg and our earlier incident here: https://status.supabase.com/incidents/qm2zp5l61l4m

While the API requests to cloudflare are more stable, we are receiving reports that DNS propagation for new projects is taking longer than normal. Cloudflare also re-added DNS to their list of affected services, so we will be monitoring for changes and will update here as we have more information.
Posted Nov 03, 2023 - 18:35 UTC